This incident has been resolved. All delayed tasks have been processed and GitGuardian services are operating normally. The issue affected async task processing on both US and EU platforms, impacting VCS historical scans (free tier and business customers), automatic severity detection, and public monitoring features. A fix was deployed and all queued tasks accumulated during the incident have now been completed.
Posted Nov 03, 2025 - 18:37 CET
Monitoring
A fix has been implemented for the processing issue affecting both US and EU platforms. During our investigation, we discovered the issue also impacted the EU platform and Public Monitoring features. The async workers are now processing the backlog of queued tasks, including VCS historical scans (free tier and business customers), automatic severity detection, and public monitoring. GitGuardian is monitoring progress as the system catches up with accumulated delays. Next update in 8 hours.
Posted Nov 03, 2025 - 17:52 CET
Investigating
GitGuardian is investigating an issue affecting free tier VCS scans and automatic severity detection on the US platform. Users may experience scans queued but not completing. We are working to resolve this issue. Next update in 10 hours.
Posted Nov 03, 2025 - 15:24 CET
This incident affected: GitGuardian Platform US (us-west-2 / Oregon) (Secret Detection - Scan Check Run).