Slowness on Check Runs

Incident Report for GitGuardian Services Status

Resolved

We deployed a fix today that addressed the check run issues. A brief database load increase was observed post-deployment with no impact on check run results.
This incident is now resolved.
Posted May 22, 2026 - 16:33 CEST

Monitoring

We are currently investigating an issue where some customers may experience intermittent spikes of slowness when processing check runs.
Our team is actively monitoring the situation and working on a fix. We will provide updates as the situation progresses.
We apologise for the inconvenience.
Posted May 21, 2026 - 17:41 CEST
This incident affected: GitGuardian Platform US (us-west-2 / Oregon) (Secret Detection - Scan Check Run).