Resolved
Resolved. Following database query optimizations and reduced load from noisy background jobs, no further performance degradation has been observed. Metrics have been stable since deployment of the fixes.
Investigating
We've identified renewed performance degradation affecting check run and realtime processing, with some customers experiencing delays of up to approximately 30 minutes. We've identified contributing factors related to database load and have deployed mitigations to reduce impact. We're continuing to investigate further improvements and will share updates as we have more information.