Resolved
This incident is now resolved. Following fixes deployed by our team, we have not observed further performance degradation, and metrics have been stable since.
Monitoring
Service has returned to normal levels and we're no longer seeing degradation. Our engineering team has applied mitigations and continues to investigate the underlying cause to prevent recurrence. We're closely monitoring the situation and will update this page as needed.
Investigating
We are continuing to investigate delays affecting check runs and GitHub Actions checks for customers. The root cause hasn't been confirmed yet, but we've applied mitigations to reduce load on our systems. We're closely monitoring the situation and will share another update as soon as we have more information.
Investigating
We are aware of delays affecting check runs and GitHub Actions checks for some customers. Our team is actively working on it. We'll post another update as soon as we have more information.