Resolved
The fix has successfully been deployed and the situation should be back to normal. Sorry for the inconvenience.
Monitoring
We are currently investigating an issue where some customers may experience intermittent spikes of slowness when processing check runs.Our team deployed a fix and is actively monitoring the situation. We will provide updates as the situation progresses.We apologise for the inconvenience.